Resolved
All impacted services have now fully recovered.
Monitoring
Requests are stabilizing for users. We’ll continue observing stability until full recovery.
Investigating
We’re currently investigating reports of a potential issue affecting one or more of our services.
Our authentication provider (Clerk) is currently experiencing issues, which may result in authentication failure or intermittent authentication failures for some users. We are monitoring the situation and will update this page as more information becomes available to us.