Elevated Latency in NA East Region
Resolved·Degraded performance

All impacted services have now fully recovered.

Wed, Feb 11, 2026, 02:45 PM
(1 week ago)
·
Affected components
Updates

Resolved

All impacted services have now fully recovered.

Wed, Feb 11, 2026, 02:45 PM

Monitoring

A fix has been deployed, and we’re monitoring the systems to ensure everything is operating as expected.

We’ll continue observing stability until full recovery.

Wed, Feb 11, 2026, 02:04 PM(41 minutes earlier)

Identified

We’ve identified the root cause of the issue and are working on a fix.

Wed, Feb 11, 2026, 01:40 PM(23 minutes earlier)

Investigating

We’re currently investigating reports of a potential issue affecting one or more of our services.

Our engineering team is actively working to identify the cause and will provide updates as more information becomes available.

Thank you for your patience while we continue our investigation.

Wed, Feb 11, 2026, 01:08 PM(32 minutes earlier)