If you notice a service disruption not yet listed here, please report it on our Discord.
No components marked as affected
Resolved
All impacted services have now fully recovered.
Identified
Discord is currently experiencing issues that may cause increased connection delays.
Incident: https://discordstatus.com/incidents/mjj0126tzs2r